I have come across a couple of issues relating to Emailing documents from Sage 200.

At one of my sites recently users were using had a mixture of Outlook 2010 and Outlook 2013. I had configured all layouts for email set up to use MAPI as the Mail provider.

The first issue this brought up was for every email Sage tried to send, an Outlook security warning would pop up.

Outlook security message

Outlook security message

This is not so bad for users if one or two emails are being sent, but imagine how this is for a batch of 100+ statements!

This issue is actually caused by a Microsoft Outlook update that is designed to prevent security breaches and is not a Sage problem. The update effectively removes the ‘Send e-mails automatically’ feature from within Format > E-mail and this can’t easily be corrected. For further information, refer to Microsoft article 262634 at http://support.microsoft.com/?kbid=262634

NB. In Outlook 2000 and 2003 the security update is installed separately, however it is built into Outlook 2007 and above. For Outlook 2013, there are Programmatic Access security settings which are generally controlled at a Group level. These should be enabled.

In Sage 200 2013 and above, this issue doesn’t occur if the report or layout has the Mail Provider set to Outlook instead of MAPI.

Having changed the Mail provider to Outlook on the layouts at my site, this identified another issue but this time for users of Outlook 2013. With the Mail Provider set as Outlook, when attempting to Email a document, a message appeared to advise that the Sage200Desktop.exe has stopped working.

StoppedWorking

Sage200Desktop.exe has stopped working error

The Problem Details section gives more information (???????):

Problem signature:

Problem Event Name: APPCRASH

Application Name: Sage200Desktop.exe

Application Version: 17.300.14086.3

Application Timestamp: 5334325b

Fault Module Name: StackHash_17c0

Fault Module Version: 6.3.9600.17630

Fault Module Timestamp: 54b0d74f

Exception Code: c0000374

Exception Offset: PCH_0F_FROM_ntdll+0x0003CC2C OS

Version:6.3.9600.2.0.0.16.7

Locale ID:2057

Additional Information 1: 17c0

Additional Information 2: 17c083e57d5c8adee4818c4ba7d6ebbb

Additional Information 3: 643b

Additional Information 4: 643b2a225326ecea5e5cb96f62ab3b6e

Troubleshooting detected that although this issue occurs for Outlook 2013, it only occurs when using Windows 8/8.1 or Server 2012/2012R2. Windows 7 machines were fine.

This is a known issue with the Sage report designer (so impacts Sage 50 and payroll also). The problem I had for my site was the resolution is to switch the layout Mail Provider to MAPI……..!

NB. The Sage200Desktop.exe has stopped working error can also occur when the Mail Provider is MAPI and Outlook is closed when attempting to Email the document.

My options for this site were:

Solution 1
Upgrade all users to Outlook 2013 and set all layouts to use MAPI.

Solution 2
Keep layouts as MAPI but for Outlook 2010 users download ‘Click Yes’ http://www.contextmagic.com/express-clickyes/

Solution 3
Sell the customer Spindle Professional

Advertisements