Tag Archive: Error Message


Service pack 3 has now been released for Sage 200 Extra 2015. There are a number fixes included as detailed in Sage 200 Extra 2015 SP3 Issues Fixed .

Sage 200 Manufacturing

Stock Projection Details

Some changes have been made to improve compatibility with Windows 8, Windows 8.1 and Windows Server 2012, these changes also make a consistent look and feel with other areas of Sage 200 Extra.

As a result of these changes, the following graphs are no longer available:

• Graph tab on Stock Projection Item Details

• Graph tab on Monitor Operation Times

• Histogram tab on Monitor Operation Times

The changes also prevents some workspace options (for example, opening, saving, Copy to Clipboard, print and the tools to change the display of the charts).

MRP – Unable to amend the first recommendation on the system

When the user runs MRP within Manufacturing for the first time, the MRP numbering sequence runs from MRP000000, rather than MRP000001.

As a consequence of this, the first recommendation will not be selectable on the MRP Recommendations form.

To renumber the recommendations you must run the MRP twice on a new dataset, before actioning or maintaining any recommendations.

Subsequently, MRP need only be run once.

Sage 200 Suite Tools

Sage 200 2015 SP3 uses a new version of ManufacturingCSVFileConversion.exe

If you attempt to use the previous tool, the following message appears:

Error launching application. Could not load file or assembly ‘Sage. Manufacturing, Version – 17.0.0.1’.

 

After upgrading a Sage 200 site to Sage 200 2015, an error message may be displayed when accessing System Administration for the first time. The message advises of an error in XML document (9, 3).

 

This is caused by not removing any Add-Ons before commencing the upgrade to Sage 200 2015.

Previously, the Add-Ons could be uninstalled in System Administration but when you try to remove the Add-Ons , the below error is displayed.

Exception has been thrown by target of an invocation

This is because in Sage 200 2015, the schema version number has changed so the Add-On trying to be removed does not have the expected schema number assigned to it and so can’t be removed.

In order to complete the upgrade:

Note: You must take a backup of the Sage 200 Configuration Database before proceeding.

  1. Close any errors and select the Add-Ons option in the left pane.
  2. Make a note of the name of each Add-On installed on the site.
  1. Backup the Sage 200 Configuration Database before proceeding.
  1. Open the configuration database in Microsoft SQL Management Studio and open the tblAddon table.
  2. Look for the Add-Ons that were noted in Step 2 in this table. For each add-on, make a note of the AddOnID in the first column.
  3. Remove the entries from the table for each of these add-ons. This should leave only the standard Sage 200 entries in the table, for example, Sage 200 Accounts, Sage 200 Bill of Materials, Sage 200 Accounts Compiled Model.
  4. Close Microsoft SQL Management Studio and re-open Sage 200 System Administrator.
  5. The core components should now install successfully. You will then need to reinstall any applicable Add-Ons, ensuring first that they have been re-compiled for use with Sage 200 2015.

Sage 200 2015 Service Pack 1 is now available.

Business Partners should note the different method of installation on Clients.

This service pack contains two files:

  • Sage200v2015SP1ClientPrerequisites.exe
  • Sage200v2015SP1.msp

On a client PC both files must be run, in that order, to ensure the service pack installs correctly.

Sage200v2015SP1ClientPrerequisites.exe checks the client files and ensures that the correct registry keys are present on the client machines. Sage 200v2015SP1.msp updates Sage 200 Extra. Failure to run the files in this order will cause errors when you try to run Sage 200 Extra 2015.

On a server, you only need to install the Sage 200v2015SP1.msp file.

Sage 200 Extra 2015 SP1 Installation and Release Notes

The following Known Issues have been resolved in Service Pack 1.

Module Issue Tracking System Reference
(where applicable)
Description
Nominal Ledger 5970 Users were unable to import a CSV file with negative budget values.
6318 When importing nominal ledger budgets, a ‘success’ message was displayed but the details were not imported.
6429 The Default Cost Centre drop-down list was not displayed on the Consolidation tab of the Nominal Ledger settings.
Desktop 6389 An ‘Unhandled Exception’ error message appears when trying to add a new feature in Menu Design mode.
6390 Updated the Workspace quick filters to display part searches. Previously, the filter would only search on the entire word (for example, typing AB would only find a customer with the name AB, it wouldn’t find Abbey etc).
6400 User preferences not retained when a user logs out of Sage 200.
6424 Adding reports to the Home Page Favourites now makes the report appear in the Summary screen.
6425 Creating a new folder in Home Page Favourites and adding the report generates an error.
6443 Error in Workspaces where the ‘OR’ filter did not work correctly. In previous versions the OR filter was working like an AND. As a result, no details were being returned by the filter.
6444 Unable to run reports or layouts from favourites.
6487 Non Taxable Receipt launches Taxable Receipt Form.
Purchase Orders 5753 Could copy an order without saving any supplier details.
6480 Multiple Delivery Dates button missing if Project Account Integration not enabled.
Sales Ledger 6451 Save and Allocate button on the Sales Ledger reverse transaction form is now read-only when reversing receipt or payment. This was active in the release version of 2015.
Stock 6455 MRP Replenishment Options missing from the Manufacturing tab on the Stock Item screen when using low screen resolution on some low-spec laptops and PCs.
Timesheets 6469 Enter Timesheet Week – Incorrect Cost rate saved.
Analysis Codes 6470 Issue when editing a newly created analysis code in Sales Order Processing or Purchase Order Processing.
Sage 200 CRM 6432 Ergonomic UI not working as expected after upgrade from 7.1.
Developers 6401 Addon fails to install when contains 2 content parts.

Sage 200 Extra 2015 SP1 Feature Updates and Issues Fixed gives some further details of items included in this update.

I have come across a couple of issues relating to Emailing documents from Sage 200.

At one of my sites recently users were using had a mixture of Outlook 2010 and Outlook 2013. I had configured all layouts for email set up to use MAPI as the Mail provider.

The first issue this brought up was for every email Sage tried to send, an Outlook security warning would pop up.

Outlook security message

Outlook security message

This is not so bad for users if one or two emails are being sent, but imagine how this is for a batch of 100+ statements!

This issue is actually caused by a Microsoft Outlook update that is designed to prevent security breaches and is not a Sage problem. The update effectively removes the ‘Send e-mails automatically’ feature from within Format > E-mail and this can’t easily be corrected. For further information, refer to Microsoft article 262634 at http://support.microsoft.com/?kbid=262634

NB. In Outlook 2000 and 2003 the security update is installed separately, however it is built into Outlook 2007 and above. For Outlook 2013, there are Programmatic Access security settings which are generally controlled at a Group level. These should be enabled.

In Sage 200 2013 and above, this issue doesn’t occur if the report or layout has the Mail Provider set to Outlook instead of MAPI.

Having changed the Mail provider to Outlook on the layouts at my site, this identified another issue but this time for users of Outlook 2013. With the Mail Provider set as Outlook, when attempting to Email a document, a message appeared to advise that the Sage200Desktop.exe has stopped working.

StoppedWorking

Sage200Desktop.exe has stopped working error

The Problem Details section gives more information (???????):

Problem signature:

Problem Event Name: APPCRASH

Application Name: Sage200Desktop.exe

Application Version: 17.300.14086.3

Application Timestamp: 5334325b

Fault Module Name: StackHash_17c0

Fault Module Version: 6.3.9600.17630

Fault Module Timestamp: 54b0d74f

Exception Code: c0000374

Exception Offset: PCH_0F_FROM_ntdll+0x0003CC2C OS

Version:6.3.9600.2.0.0.16.7

Locale ID:2057

Additional Information 1: 17c0

Additional Information 2: 17c083e57d5c8adee4818c4ba7d6ebbb

Additional Information 3: 643b

Additional Information 4: 643b2a225326ecea5e5cb96f62ab3b6e

Troubleshooting detected that although this issue occurs for Outlook 2013, it only occurs when using Windows 8/8.1 or Server 2012/2012R2. Windows 7 machines were fine.

This is a known issue with the Sage report designer (so impacts Sage 50 and payroll also). The problem I had for my site was the resolution is to switch the layout Mail Provider to MAPI……..!

NB. The Sage200Desktop.exe has stopped working error can also occur when the Mail Provider is MAPI and Outlook is closed when attempting to Email the document.

My options for this site were:

Solution 1
Upgrade all users to Outlook 2013 and set all layouts to use MAPI.

Solution 2
Keep layouts as MAPI but for Outlook 2010 users download ‘Click Yes’ http://www.contextmagic.com/express-clickyes/

Solution 3
Sell the customer Spindle Professional

When logging in to Sage 200 the following error will occur due to certain Authentication settings being configured incorrectly. The error will only be on the clients machines. Logging in to Sage 200 on the server will not cause this error.

Communication Error

IIS Windows authentication settings

  1. Within IIS, expand Sites > select Sage 200 App Services > double-click the Authentication icon in the Features area.
  2. Select Windows Authentication. Ensure this is set to Enabled. If not, select Enable in the Actions panel on the right.
  3. Also in the Actions panel, select Advanced Settings…
  4. Ensure the checkbox for ‘Enable Kernel-mode authentication’ is ticked > OK.
  5. Reset IIS

IIS Anonymous Authentication settings

  1. Within IIS, expand Sites > select Sage 200 App Services > double-click the Authentication icon in the Features area.
  2. Select Anonymous Authentication.. Ensure this is set to Enabled. If not, select Enable in the Actions panel on the right.
  3. Also in the Actions panel, select Edit…
  4. Ensure ‘Specific user’ is selected > Set…
  5. Enter the fully qualified Sage 200 Services username and password. This is the username and password you specified during the installation of Sage 200. For example, <domain>\Sage200Services.
  6. Press OK and reset IIS.

LAN Manager Authentication level

  1. Select Start > Control Panel > Administrative Tools > Local Security Policy.
  2. Double-click the Local Policies folder and select Security Options.
  3. From the list of policies, double-click ‘Network security: LAN Manager authentication level’.
  4. From the drop-down list, select ‘Send LM & NTLM – use NTLMv2 session security if negotiated’ and select OK.

If the error persists…

  • If you are using a Workgroup, password protected sharing will cause the above message to appear. This should be turned off within the Control Panel > Network and Sharing Centre > Change Advanced Sharing Settings.
  • Ensure the server that hosts the Sage 200 Web Services has been added as trusted site within Internet Explorer Options. You can access this within Internet Explorer > Tools > Internet Options > Security tab > Trusted Sites > Sites.

Where an IIS reset is required above, all users must be logged out of Sage 200 and indeed any other system which use’s IIS.

‘Login failed for user ‘.’ Please run System Administration to check company settings.’ error

2013 - Login failed for user

Check the following points:

  • Ensure the Windows user has been linked to the relevant Sage user in System Administration.
  • The Windows user, e.g. ‘JohnBull’, has been included as a user in the ‘Sage Users’ group which is set up as part of the installation process.
  • Check that the ‘Sage Users’ and ‘Sage Administrators’ groups have sufficient permission to access the Sage shared folder (by default, C:\Sage).
  • The ‘Sage Services’ user set up as part of the installation process must have sufficient security permissions on the Sage shared folder.
  •  IIS v8 only – Ensure ‘HTTP Activation’ has been enabled within .NET 4.5 as per the below:

2013 - Login failed for user_IISv8HTTPactivation

There is a compatibility issue with Sage 2013 Online v9.0 and the latest version of Payroll 19.02.157 which has update 4.

When logging on you get the following error box and Sage 200 won’t open:

Sage Payroll and 2013 Online issue

This is being looked into by Sage and they advised it will be fixed in v9.1 which should be released in the next 3-4 weeks.

The only workaround is to use a machine that doesn’t have this Payroll installed

An issue has been found within both SOP and POP, where by an exception error is given when a user tries to amend an order that contains multiple lines and the user has re-sorted the lines by the ‘Complete’ column.

A hotfix has been released. This is only relevent to Sage 200 SP3.

A known issue has been fixed for Sage 200 2011 SP3.

Some Manufacturing sites found that when recording a POP Invoice for One-Off Works Orders it causes an exception:

1. Create a One-Off Works Order with components that have unconfirmed costs.

2. Raise a POP order for the components and receive in full.

2. Allocate, issue and complete the Works Order.

3. Fully record the POP invoice.

System generates a “Divide By Zero” exception.

The known issue is 4627.  Sage has released a hotfix that must be applied to  Sage 200 2011 sp3 only.

Be aware of a known issue in Sage 200 2011 SP3 that affects Manufacturing WIP postings. It has be found that incorrect cost is posted to the WIP nominal account, when responding to “Cost of Sale” posting from POP if multiple POP Invoices are recorded:

1. Create a Works Order with components that have unconfirmed costs.

2. Raise a POP order for the components and receive in full on multiple GRNs.

3. Allocate, issue and complete the Works Order.

4. Part record the POP invoice.

5. Fully record rest of POP invoice.

Invalid nominal postings are made for the cost of sales on the 2nd GRN.

This known issue is logged as issue 4591, however a hotfix has been released and should be installed for Manufacturing sites running Sage 200 2011 SP3.